Announcement Announcement Module
Collapse
No announcement yet.
DMServer 2.0 and Eclipse Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • DMServer 2.0 and Eclipse

    Hi,
    I have updated all our toolchain to DMServer2.0 however I now need to update the eclipse toolchain. In house we have upgraded to use the plan file functionality as this makes our lives a lot more pleasant than PARs for deployments.

    Is there an update for the Eclipse plugins to support DMServer 2.0 ? and more importantly to support deployment of Plans from within Eclipse to the Server ?.

    I tried the existing plugins and they don't even like play with 2.0.0.RC1 very much - didn't even start the server. Command line is currently working but it is handy to have the eclipse side to keep the GUI only developers happy.

    Any thoughts / help appreciated.

    ~Patsy

    PS - we don't mind trying bleeding edge versions of the plugins for eclipse (we have been running off an integration build of 2.0.0 for a while now before RC1 came out).

  • #2
    The most recent nightly builds of STS contain support for plans. Start with STS 2.3.0 as a base and update from http://dist.springsource.com/snapshot/DMS-TOOLS/nightly.

    Please use the dm Server tooling forum if you have any issues or questions with the tooling.

    Comment


    • #3
      Thanks up and running

      You also need to point at the nightly Spring IDE updates before you can get the DM Tools to update http://dist.springsource.com/snapshot/IDE/nightly


      I had a bit of trouble with the deployment of the bundles but that is probably my fault. It is mainly around how to do development work with a bundle and a plan.

      If I have a bundle, that I am actively working on in Eclipse (referenced by my plan - also in eclipse), I can add the plan to the server and it appears to add the "bundle" as well. But the bundle does not appear to be pushed to the server (missing dependency). I either have to build and drop the bundle in manually or add it as a separate project entity to the server (this sometimes works). This may be my configuration - not sure if there is much "help" or "docs" for this setup yet.

      The active development/deployment of a bundle (within a plan) appears still a little weird at times but a definite improvement

      Many thanks

      Comment

      Working...
      X