Announcement Announcement Module
Collapse
No announcement yet.
uses constraint failures problem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • uses constraint failures problem

    Hi ,

    When I am trying to deploy my application which is properly running on M4 or before in to latest night snap builds. it is giving the problem like

    user conflict reported, but no uses constraint failures found

    Code:
    [2009-12-02 10:11:28.507] fs-watcher                   <HD0001I> Hot deployer processing 'CREATED' event for f
    ile 'com.ocimum.btree.rest.jar'.
    [2009-12-02 10:11:29.085] fs-watcher                   <DE0056I> Installing bundle 'com.ocimum.btree.rest' ver
    sion '5.0.1.0'.
    [2009-12-02 10:11:30.616] fs-watcher                   <DE0057I> Installed bundle 'com.ocimum.btree.rest' vers
    ion '5.0.1.0'.
    [2009-12-02 10:11:30.631] fs-watcher                   <DE0059I> Starting bundle 'com.ocimum.btree.rest' versi
    on '5.0.1.0'.
    [2009-12-02 10:11:31.131] start-signalling-1           <DE0060I> Started bundle 'com.ocimum.btree.rest' versio
    n '5.0.1.0'.
    [2009-12-02 10:11:36.630] fs-watcher                   <HD0001I> Hot deployer processing 'CREATED' event for f
    ile 'com.ocimum.btree.mw.util.jar'.
    [2009-12-02 10:11:37.037] fs-watcher                   <DE0056I> Installing bundle 'com.ocimum.btree.mw.util'
    version '5.0.1.0'.
    [2009-12-02 10:11:55.112] fs-watcher                   <ME0003I> Dump 'serviceability\dump\200912021011269' ge
    nerated
    [2009-12-02 10:11:55.644] fs-watcher                   <DE0073E> Installation of bundle 'com.ocimum.btree.mw.u
    til' version '5.0.1.0' failed. com.springsource.kernel.osgi.framework.UnableToSatisfyBundleDependenciesExcepti
    on: Unable to satisfy dependencies of bundle 'com.ocimum.btree.mw.util' at version '5.0.1.0': Cannot resolve:
    com.ocimum.btree.mw.util
        Resolver report:
             Uses conflict reported, but no uses constraint failures found.
    
            at com.springsource.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiReso
    lveStage.java:54)
            at com.springsource.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.j
    ava:71)
            at com.springsource.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPi
    peline.java:81)
            at com.springsource.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.
    java:50)
            at com.springsource.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.j
    ava:71)
            at com.springsource.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.
    java:50)
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(Pi
    pelinedApplicationDeployer.java:284)
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedAppl
    icationDeployer.java:166)
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplic
    ationDeployer.java:138)
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplica
    tionDeployer.java:202)
            at com.springsource.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystem
    Listener.java:185)
            at com.springsource.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSyst
    emListener.java:89)
            at com.springsource.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:182)
            at com.springsource.util.io.FileSystemChecker.check(FileSystemChecker.java:145)
            at com.springsource.kernel.deployer.hot.WatchTask.run(WatchTask.java:69)
            at java.lang.Thread.run(Thread.java:619)
    
    [2009-12-02 10:11:55.675] fs-watcher                   <DE0058E> Install failed for bundle 'com.ocimum.btree.m
    w.util' version '5.0.1.0'.
    [2009-12-02 10:11:55.675] fs-watcher                   <DE0018E> Unable to install application from location '
    file:/E:/SPRING~3.CI-/pickup/com.ocimum.btree.mw.util.jar'. Could not satisfy constraints for bundle 'com.ocim
    um.btree.mw.util' at version '5.0.1.0'. Cannot resolve: com.ocimum.btree.mw.util
        Resolver report:
             Uses conflict reported, but no uses constraint failures found.
    .
    [2009-12-02 10:11:55.690] fs-watcher                   <HD0002E> Hot deploy failed for file 'com.ocimum.btree.
    mw.util.jar'. com.springsource.kernel.deployer.core.DeploymentException: Dependency satisfaction failed
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(Pi
    pelinedApplicationDeployer.java:287)
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedAppl
    icationDeployer.java:166)
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplic
    ationDeployer.java:138)
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplica
    tionDeployer.java:202)
            at com.springsource.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystem
    Listener.java:185)
            at com.springsource.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSyst
    emListener.java:89)
            at com.springsource.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:182)
            at com.springsource.util.io.FileSystemChecker.check(FileSystemChecker.java:145)
            at com.springsource.kernel.deployer.hot.WatchTask.run(WatchTask.java:69)
            at java.lang.Thread.run(Thread.java:619)
    Caused by: com.springsource.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisf
    y dependencies of bundle 'com.ocimum.btree.mw.util' at version '5.0.1.0': Cannot resolve: com.ocimum.btree.mw.
    util
        Resolver report:
             Uses conflict reported, but no uses constraint failures found.
    
            at com.springsource.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiReso
    lveStage.java:54)
            at com.springsource.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.j
    ava:71)
            at com.springsource.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPi
    peline.java:81)
            at com.springsource.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.
    java:50)
            at com.springsource.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.j
    ava:71)
            at com.springsource.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.
    java:50)
            at com.springsource.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(Pi
    pelinedApplicationDeployer.java:284)
            ... 9 common frames omitted

  • #2
    Mahesh, can you please open a JIRA issue for this, attaching the bundle (in binary form) that exhibits the problem and anything non-standard upon which it depends?

    Thanks,
    Andy

    Comment


    • #3
      Posted at JIRA DMS-2157

      Comment


      • #4
        Thanks, Mahesh.

        Can you please attach a bundle that reproduces the problem in binary form, i.e. as a jar file. Also, can you provide us with any non-standard bundles upon which the bundle depends, or at least with pointers to where we can download them?

        Comment


        • #5
          Andy,

          I Just updated the jira with the my bundle as an attachment

          Comment

          Working...
          X