Announcement Announcement Module
Collapse
No announcement yet.
SOAP security bundle has unsatisfied dependencies Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SOAP security bundle has unsatisfied dependencies

    We have found a possible error in the springsource enterprise repository. The org.springframework.ws.soap.security bundle is depending on a package that isn't exported by any bundles in the repository:

    Code:
        Resolver report:
            A Require-Bundle could not be resolved. Caused missing constraint <Require-Bundle: org.springframework.ws.soap.security; bundle-version="0.0.0"> in bundle <sk.dvsk.dvg.fps.person-registration-plugin_1.0.0>
            An Import-Package could not be resolved. Caused missing constraint <Import-Package: com.sun.xml.wss; version="0.0.0"> in bundle <org.springframework.ws.soap.security_1.5.8.A>
    Did we miss something or is this really an inconsistency in the repository?

  • #2
    The com.sun.xml.wss package is described here and seems to be part of Sun's web services implementation. Unless that package is included in Sun's JRE, which it doesn't seem to be, you're right - it's a missing transitive dependency in the Enterprise Bundle Repository.

    You may like to raise a defect against the EBR.

    Meanwhile, if you can find a JAR that provides the package, you can run bundlor against it yourself to get a valid bundle.

    Hope that helps.

    Comment

    Working...
    X