Announcement Announcement Module
Collapse
No announcement yet.
Error with Struts 2 and Tiles in DM 2 M5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error with Struts 2 and Tiles in DM 2 M5

    I received the following error using Struts 2 and Apache Tiles 2.

    I have added the following (downloaded from SpringSource Repository) under repository\usr

    com.springsource.org.apache.commons.beanutils-1.8.0.jar,
    com.springsource.org.apache.commons.collections-3.2.1.jar,
    com.springsource.org.apache.commons.digester-1.8.1.jar,
    com.springsource.org.apache.tiles-2.0.5.jar,
    com.springsource.org.apache.tiles.core-2.0.5.osgi.jar,
    com.springsource.org.apache.tiles.jsp-2.0.5.jar

    Also I have used BND to create the following bundles and added them under repository\usr

    struts2-core-2.0.14.jar,
    struts2-spring-plugin-2.0.14.jar,
    struts2-tiles-plugin-2.0.11.1.jar

    Code:
    [2009-10-21 13:00:29.125] fs-watcher                   com.springsource.osgi.medic.eventlog.default                     DE0018E Unable to install application from location 'file:/C:/springsource-dm-server-2.0.0.M5/pickup/account.war'. Could not satisfy constraints for bundle 'AccountNew' at version '1.0.0'. Cannot resolve: AccountNew
        Resolver report:
            An Import-Package could not be resolved. Caused missing constraint <Import-Package: org.apache.tiles.impl; version="0.0.0"> in bundle <AccountNew_1.0.0>
            Uses violation: <Import-Package: org.apache.commons.logging.impl; version="[1.1.1,2.0.0)"> in bundle <com.springsource.org.apache.commons.digester_1.8.1>
                Possible matches:
                    	<Export-Package: org.apache.commons.logging.impl; version="1.1.1"> from <com.springsource.slf4j.org.apache.commons.logging_1.5.6>
                        No dependent constraint mismatch. Try refreshing the <com.springsource.slf4j.org.apache.commons.logging_1.5.6> bundle.
            An Import-Package could not be resolved. Caused missing constraint <Import-Package: org.apache.tiles.context; version="[2.0.5.osgi,2.0.5.osgi]"> in bundle <com.springsource.org.apache.tiles.jsp_2.0.5>
            An Import-Package could not be resolved. Caused missing constraint <Import-Package: org.apache.tiles.context; version="[2.0.5.osgi,2.0.5.osgi]"> in bundle <struts2-tiles-plugin-2.0.11.1_0.0.0>
            An Import-Package could not be resolved. Caused missing constraint <Import-Package: org.apache.commons.digester; version="[1.8.0,2.0.0)"> in bundle <com.springsource.org.apache.tiles.core_2.0.5.osgi>
    . 
    [2009-10-21 13:00:29.140] fs-watcher                   com.springsource.osgi.medic.eventlog.default                     HD0002E Hot deploy failed for resource 'C:\springsource-dm-server-2.0.0.M5\pickup\account.war'.

  • #2
    You may be able to get closer to the root cause of the problem by exploring the state dump using the admin console. See our screencast if you are unfamiliar with how to do this.

    Meanwhile, please would you raise a JIRA with *binaries* sufficient to reproduce the problem and we will take a look. We actually only need bundles with manifests as the other contents of the bundles are irrelevant to this problem.
    Last edited by Glyn Normington; Oct 22nd, 2009, 03:26 AM.

    Comment

    Working...
    X