Announcement Announcement Module
Collapse
No announcement yet.
Failed to start bundle 'org.springframework.osgi.core' Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed to start bundle 'org.springframework.osgi.core'

    Hi!

    I'm getting the following error when starting the dmServer:

    Code:
    [2009-07-20 17:54:26.440] main                     <SPKB0001I> Server starting.
    [2009-07-20 17:54:27.898] main                     <SPOF0001I> OSGi telnet console available on port 2401.
    [2009-07-20 17:54:34.710] main                     <SPKB0002E> Start failed:
    com.springsource.server.osgi.framework.OsgiFrameworkException: Failed to start bundle 'org.springframework.osgi.core'
    	at com.springsource.server.osgi.framework.equinox.EquinoxBundleInstaller.startBundle(EquinoxBundleInstaller.java:378)
    	at com.springsource.server.osgi.framework.equinox.EquinoxBundleInstaller.doInstallBundle(EquinoxBundleInstaller.java:123)
    	at com.springsource.server.osgi.framework.support.AbstractBundleInstaller.installBundleFromLocation(AbstractBundleInstaller.java:170)
    	at com.springsource.server.osgi.framework.support.AbstractBundleInstaller.installBundleFromDefinition(AbstractBundleInstaller.java:242)
    	at com.springsource.server.osgi.framework.support.AbstractBundleInstaller.installBundle(AbstractBundleInstaller.java:137)
    	at com.springsource.server.osgi.framework.support.AbstractBundleInstaller.installBundle(AbstractBundleInstaller.java:109)
    	at com.springsource.server.kernel.bootstrap.KernelBootstrap.start(KernelBootstrap.java:73)
    	at com.springsource.server.kernel.bootstrap.Bootstrap.main(Bootstrap.java:73)
    Caused by: org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Package uses conflict: Import-Package: org.springframework.beans.factory.support; version="[2.5.4.A,3.0.0)"
    	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
    	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:265)
    	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:257)
    	at com.springsource.server.osgi.framework.equinox.EquinoxBundleInstaller.startBundle(EquinoxBundleInstaller.java:376)
    	... 7 more
    I don't understand why 'org.springframework.osgi.core' cannot load the version 2.5.6.A since this is the one I have installed. What am I doing wrong?


    Thank you very much.

    Regards,
    Victor

  • #2
    Hi!

    I'm creating a WebService to work on the dmServer, and I imported this bundle:
    org.springframework.ws;version="[1.5.7.A,1.5.7.A]"

    and it seems that this bundle required:
    org.springframework.beans version 2.5.6.SEC01

    somehow when Maven downloaded in my ~/.m2/repository this bundle, the dmServer stopped working. I just deleted this version and now the dmServer starts again, but of course the WebService is not working.
    Should I delete the 2.5.6.A version and use the 2.5.6.SEC01 to make everything work?
    BTW, what this SEC01 means? SECurity patch? I couldn't find it in the FAQ:
    http://www.springsource.com/repository/app/faq

    Thank you!

    Best regards,
    Victor

    Comment


    • #3
      Yes, you can delete the 2.5.6.A bundles and use the 2.5.6.SEC01 bundles instead. Yes, it was a security patch although I can't access the details on the SpringSource web site!

      Comment

      Working...
      X