Announcement Announcement Module
Collapse
No announcement yet.
Spring Security version range '[2.0.4.A, 2.0.4.A]' could not be satisfied. Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Security version range '[2.0.4.A, 2.0.4.A]' could not be satisfied.

    Can any one help me in solving the following issue, I am using Spring Dm Server 275 night built version.

    [2009-07-09 17:53:19.355] nection(66)-192.168.3.64 <SPDE0018E> Unable to install application from location 'file:///E:/springsource-dm-server-2.0.0.CI-R327-B275/stage/com.ocimum.btree.api.war'. Could not satisfy constraints for bundle 'com.ocimum.btree.api' at version '1.0.0'. Import-Bundle with symbolic name 'org.springframework.security' in version range '[2.0.4.A, 2.0.4.A]' could not be satisfied.

    Thank you in advance.

  • #2
    If you are using dm server 2.0 CI builds, it would make sense.

    2.0 ships with Spring 3.0 and springsecurity 2.0.4.A has a version range of
    [2.5.x, 3.0.0) - from 2.5.6 up to but not including 3.0.0.

    Just ran into it last night also. Had to upgrade to SpringSecurity 3.0.0.M1 in mean time.

    Comment

    Working...
    X