Announcement Announcement Module
Collapse
No announcement yet.
problem with apache-cxf bundle Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem with apache-cxf bundle

    Hi,

    I have a serious problem with the running of apache cxf bundle.
    I have follow this thread at the letter http://forum.springsource.org/showthread.php?t=72299
    but I can't get this bundle up and running.

    Apache cxf single bundle:
    It's work only if I deploy it in the 'pickup' directory but in this case i don't use it with eclipse because the IDE don't see its exported-package. If I add the 'pickup' directory to the provisioning section (file server.config) I obtain the same error due to the lenght of the header.

    Apache cxf-bundle-minimal:
    If I add this in the pickup directory I obtain the header lenght error. If I add this to the 'repository/bundles/usr/' directory I don't see the bundle in the osgi console, without even the state INSTALL, it isn't present in the list of bundle.

    How can I do?
    I am trying to make cxf-bundle myself, staring from the source code, but it's a very bad work and probably it won't work.

    Bye to everyone!

  • #2
    Which version of dm Server are you running this on? The fix only went in after 2.0.0.M2 was released, so you'll have to use a nightly build, or wait until 2.0.0.M3 has been released.

    Comment


    • #3
      I currently using community 1.0.2 version. The nightly build versions are quite stable?

      Thanks a lot!!

      Comment


      • #4
        Yes, they should be. Please give the 2.0 builds a try, and let us know if you have any problems.

        Comment


        • #5
          hi,

          I've tried with the springsource-dm-server-2.0.0.CI-R337-B285 nightly-build, but nothing is going well.
          When I put cxf-bundle-minimal-2.2.1 in '/repository/bundles/usr' I can't see this bundles with eclipse sts and neither in the osgi console (command 'ss'). The directory '/repository/bundles/usr' is present in the server SearchPattern and if I put in any other bundles, also custom bundle, they are seen correctly and they running up perfectly.

          It seems to be a problem of cxf bundle, may be?

          Thanks. Bye!

          Comment


          • #6
            Hi,

            I am using cxf-bundle-minimal-2.2.1 in spring-dm-server-2.0.0.M2 and using version 2.0.0.M5 of the SpringSource dm server Eclipse integration and I can see the cxf bundle among my repository/bundles/usr bundles and deployed bundles are able to access it.

            Note that the bundle will not be seen from the OSGi console at runtime unless a bundle has been deployed on the server that depends on (some package from) the cxf bundle. The repository bundles are pulled into the server runtime on demand.

            regards, Peter

            Comment


            • #7
              Hi,

              Thank you for the suggestion of your experience with cxf.
              Can I ask you where I you have downloaded the "2.0.0.M5 of the SpringSource dm server Eclipse integration" because I can't find it.

              Thanks a lot!

              Bye bye

              Comment


              • #8
                The dm server tools (http://www.springsource.org/dmservertools) has an eclipse update site:

                http://www.springsource.org/milestone/e3.4

                Comment

                Working...
                X