Announcement Announcement Module
Collapse
No announcement yet.
missing constraint error on deploying (dmserver / sts / greenpages) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • missing constraint error on deploying (dmserver / sts / greenpages)

    Hiho @all! :-)

    I'm failing to set up dmserver 2.0.0m2 with sts 2.0.2 and greenpages sample app 1.1.0.
    I followed the "getting started" tutorial step by step, but deploying of the greeenpages.web package fails with missing constraint error:

    Missing constraint: <Import-Package: org.springframework.web.servlet.mvc.annotation; version="[2.5.6.A,3.0.0)"> in bundle <greenpages.web_1.0.0>
    Although the org.springframework.web.servlet bundle v2.5.6.A is referenced by greenpages.web project via maven dependency.
    repository.conf in springsource-dm-server/config directory has been edited to match "getting started" tutorial, too.

    any help would be very appreciated

    thank you and best greez
    betasheet

  • #2
    Hiho again,

    some updates:

    I tried STS 2.1.0M2, which results in no more errors in eclipse (a la "missing constraint") but starting and deploying the greenpages.web package still results in a "missing constraint" error.

    I suppose, this is up to something with dm-server not loading / finding the needed maven dependencies.
    My repository.config in springsource-dm-server/config directory looks like this:
    Code:
    {
        "repositories" : {
    		"bundles-subsystems" : {
    			"type" : "external",
    			"searchPattern" : "repository/bundles/subsystems/{subsystem}/{component}"
    		},
    		"bundles-ext" : {
    			"type" : "external",
    			"searchPattern" : "repository/bundles/ext/{bundle}"
    		},
    		"bundles-usr" : {
    			"type" : "external",
    			"searchPattern" : "repository/bundles/usr/{bundle}"
    		},
    		"libraries-ext" : {
    			"type" : "external",
    			"searchPattern" : "repository/libraries/ext/{library}"
    		},
    		"libraries-usr" : {
    			"type" : "external",
    			"searchPattern" : "repository/libraries/usr/{library}"
    		},
    		"bundles-m2" : {
    			"type" : "external",
    			"searchPattern" : "{user.home}/.m2/repository/**/{bundle}"
    		}
        },
    	"repositoryChain" : [
    		"bundles-subsystems",
    		"bundles-ext",
    		"bundles-usr",
    		"bundles-m2",
    		"libraries-ext",
    		"libraries-usr"
    	]
    }
    Is there anything I am missing?

    Thanks for your help
    betasheet

    Comment


    • #3
      Apologies for the problems you've been having. The good news is that we're working on them in our current sprint.

      In the meantime, I'd recommend working with dm Server 1.0.2 and the matching Getting Started Guide. The updated guide will be released alongside dm Server 2.0 M3 in the next few weeks.

      Comment


      • #4
        Thanks for your answer, Andy :-)

        Tried using dmserver 1.0.2, and this one seems to be able to locate bundles in the maven repository - problems vanished ;-)

        best greez
        betasheet

        Comment

        Working...
        X