Announcement Announcement Module
No announcement yet.
Axis 1.4 bundle issues with commons logging Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Axis 1.4 bundle issues with commons logging

    I am using the axis 1.4 bundle from the spring source enterprise bundle repository and when using it I receive an exception :

    Caused by: java.lang.ExceptionInInitializerError
    at org.apache.axis.handlers.BasicHandler.<clinit>(Bas
    at org.apache.axis.client.Service.getAxisClient(Servi
    at org.apache.axis.client.Service.<init>( :113)
    at ---.<init>(
    at ---.afterPropertiesSet(
    at AutowireCapableBeanFactory.invokeInitMethods(Abstr
    at AutowireCapableBeanFactory.initializeBean(Abstract
    ... 17 more
    Caused by: org.apache.commons.discovery.DiscoveryException: No implementation defined for org.apache.commons.logging.LogFactory
    at fyAncestory(
    at ifyAncestory(
    at Instance(
    at ewInstance(
    at on.find(
    at on.find(
    at org.apache.axis.components.logger.LogFactory$ (
    at Method)
    at org.apache.axis.components.logger.LogFactory.getLo gFactory(
    at org.apache.axis.components.logger.LogFactory.<clin it>(
    ... 24 more

    I am pax runner to launch equinox with pax logging.

    I am using these bundles (and others) from the spring source enterprise bundle repository :


    I have also tried deploying commons logging 1.1.1 and setting the system property org.apache.commons.logging.LogFactory=org.apache.c ommons.logging.impl.SLF4JLogFactory. but the same error occurs.

  • #2
    pax-logging may be the culprit

    I just filed this issue:

    It appears that because pax-logging's LogFactory class's signature is slightly different commons-discovery clients (Axis 1.4 being one of them) cannot use pax-logging as a drop in replacement.