Announcement Announcement Module
Collapse
No announcement yet.
Struts support Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Struts support

    Hello !

    I'm trying to use Struts 1 on a Spring DM Server. I would like to create a Web Bundle (Module-Type: Web) using Struts as a regular OSGi (library) bundle.

    I found lots of tutorials about integrating Struts and Spring (speaking about ContextLoaderPlugIn or DelegatingActionProxy), telling how to change the struts-config.xml.

    But I assume that the Struts' ActionServlet has to be working in the first place (to be able to use the Struts config file). And it is not. Adding the ActionServlet in my web.xml makes the server unable to deploy my application (without throwing any error, to add some fun).

    I'm new in both Spring and Struts worlds, so 3 questions :
    - Is it ok to deploy Struts as an OSGi bundle, using it in a Web Bundle ?
    - Am I totaly wrong about setting up the ActionServlet as in a regular web application (in web.xml) ?
    - Do you know some basic tutorial explaining Struts integration *from the beginning*, for newbies ?

    Hope I RTFM enough before posting for help.

    GS

  • #2
    Ok, nobody seems interested by this topic. I still add conclusions from my last test.

    Seems there were some issues with my Struts library bundle. I'm now using the bundle from the SpringSource repository, and my project is deployed correctly.
    More, global forwards in my struts-config.xml are working, either to an action or to a jsp. But not the actions themselves : visiting something.do shows a 404 error : "The servlet action is not available" (*.do being mapped to an ActionServlet called "action").

    I also tried to make a web module with the blank application from Struts 1.2.9 (basically copying all jsp and xml files from WebContent to MODULE-INF). Nothing. Same as above.

    So, please, an idea, a tips, anything...
    Last edited by GlanduSchmoldu; Apr 2nd, 2009, 12:30 PM. Reason: Forgot something

    Comment

    Working...
    X