Announcement Announcement Module
Collapse

Spring Modules forum decommissioned in favor of Spring Extensions

As the Spring Modules project has been replaced by the Spring Extensions (http://www.springsource.org/extensions) project, this forum has been decommissioned in favour of Spring Extensions one at:
http://forum.springsource.org/forumdisplay.php?f=44

Please see the Spring Extensions home page for a complete list of current projects in Java, .NET and ActionScript. You can also propose one if you want.

Cheers,
Costin Leau
SpringSource - http://www.SpringSource.com- Spring Training, Consulting, and Support - "From the Source"
http://twitter.com/costinl
See more
See less
spring jbpm : how to use Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • spring jbpm : how to use

    Hi All,
    I'm newbie to spring and my question may be of primary kind to u all.
    I need to use JBPM ans so downloaded "spring-projects/spring-jbpm" from CVS.
    I tried to make "ant build" ; but as this build referes to "common-targets" in parent directory, I checked out whole folder viz."/spring-projects/"
    In the projects dir, I did "ant gen-release-bins".
    Then,
    cd spring-jbpm/
    ant

    I got the following trace:
    WARN: ::::::::::::::::::::::::::::::::::::::::::::::
    WARN: :: UNRESOLVED DEPENDENCIES ::
    WARN: ::::::::::::::::::::::::::::::::::::::::::::::
    WARN: :: springframework/spring-dao-1.2.4: not found
    WARN: :: springframework/spring-beans-1.2.4: not found
    WARN: :: springframework/spring-hibernate-1.2.4: not found
    WARN: :: springframework/spring-context-1.2.4: not found

    ...The list continues...

    BUILD FAILED
    impossible to resolve dependencies: resolve failed - see output for details.
    What is the thing I'm missing out in this?
    Or, what is the exact way to use "spring-jbpm"?

    Any help is appreciated.

    thanks,
    anagha

  • #2
    spring-jBPM build

    Instead of doing 'ant gen-release-bins', go to the spring-jbpm directory and run 'ant build'. Since you've checked out spring-projects the build can now find all it's properties and files.

    Comment


    • #3
      Yes...I did the same.
      As mentioned in the question I did "ant" in the "jbpm" directory.
      I got the errors related to dependencies.
      Any suggesions?

      Comment


      • #4
        When did you checkout the sources - I have looked briefly at the logs and there was an upgrade to 1.2.5 so the 1.2.4 should not be needed anymore. Can you please check that your sources are up to date and see what is going on in the configuration file?
        Have you tried running ant first in the main directory ? (just guessing..)

        Comment


        • #5
          Project "spring-projects" checked out from Eclipse IDE :
          Following is the environment :
          Host : cvs-pserver.sourceforge.net. (As with cvs.sourceforge.net connection was not successful) This was as per in the CVS docs)
          http://sourceforge.net/docman/displa...894#connection

          Port : 443 (As with default port 2401, connection was not successful)
          Repository Path : /cvsroot/springframework
          User : anonymous
          Password :
          Conection Type : pserver

          After successful connection :
          I checked out from HEAD -> spring-projects.
          Date : 28th Sept, 2005
          Anything wrong in this environment?

          Can you please check that your sources are up to date and see what is going on in the configuration file?
          What settings need to be checked in the configuration file?
          thanks,
          Anagha

          Comment


          • #6
            The project was checked out completely. Spring-projects is not yet released, it's still in an alpha form (from what I know) and that's why I think there might some hicups in the build process.
            I'm suggesting to look at the ant file and figure out what is not working in there. You can also try the spring/spring modules mailing list to get some help.

            I know that Rob will probably come back from the holiday next week and, as the commiter of the code can probably help you out.

            Comment


            • #7
              I just updated the ivy.xml file so that it will bring down the 1.2.5 Spring dependencies now so the build should succeed just fine. You'll need to download Ivy 1.2a as well for this to succeed.

              Rob

              Comment


              • #8
                Checked out latest spring-projects from the CVS

                Perfomed the following steps :
                • cd common-build/
                  ant clean
                  ant gen-release-sources
                  ant release
                  ant gen-release-bins
                  ant tests
                  BUILD FAILED
                  /home/anagha/eclipseProjects/spring-projects/build-spring/build.xml:118: The following error occurred while executing this line:
                  Target `run-ltests' does not exist in this project.
                  cd ../spring-jbpm/
                  ant
                  BUILD FAILED
                  /home/anagha/eclipseProjects/spring-projects/common-build/common-targets.xml:516: Compile failed; see the compiler error output for details.

                What is the exact thing I'm missing out?

                Comment


                • #9
                  First you have to fix the syntax error in JbpmTemplate line 170 missing semicolon.


                  Turns out you'll need at least Ant 1.6.2 to run the junit tests. I did the following using Ant 1.6.5 embedded in Eclipse 3.1. First, under window->prefs->ant add the junit.jar to the classpath, I know ant is supposed to come with that but without it eclipse complained it couldn't find the junit.framework.Test class. Second, from the spring-jbpm project run:

                  ant clean
                  ant tests-dist

                  The tests pass and the spring-jbpm distro jar resulted.

                  Rob mentioned you'll need to download Ivy 1.2a. For me that came down once I synchronized with the main springframework/spring-projects CVS module.

                  Comment


                  • #10
                    Gah! I can't believe I committed that I as using that bit of code to check out an API issue and accidentally left it in there.

                    Fixed now.

                    Rob

                    Comment


                    • #11
                      Thanks Rob

                      Comment

                      Working...
                      X