Announcement Announcement Module

Spring Modules forum decommissioned in favor of Spring Extensions

As the Spring Modules project has been replaced by the Spring Extensions ( project, this forum has been decommissioned in favour of Spring Extensions one at:

Please see the Spring Extensions home page for a complete list of current projects in Java, .NET and ActionScript. You can also propose one if you want.

Costin Leau
SpringSource - Spring Training, Consulting, and Support - "From the Source"
See more
See less
Java 1.6 and springmodules Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Java 1.6 and springmodules

    When running Tomcat 6 with Java 6 and using the bean-validator sample in springmodules 0.9, I get the following error:

    Error creating bean with name 'handlerMapping' defined in ServletContext resource [/WEB-INF/validator-servlet.xml] [...] nested exception is java.lang.NoSuchFieldError: IS_JAVA_1_6

    The validator works fine in Java 5. Is springmodules not compatible with Java 6? If not, does anyone have an idea of when it will be Java 6 ready?

  • #2
    I had the same problem when used old commons-lang lib.
    Try use version 2.4 or latest, for resolve it.


    • #3
      I am having the same problem eventhough i have commons lang 2.4 version.

      Can anyone please help me on this.



      • #4
        Bump to top - I'm getting an error similar to anyone have a solution?

        EDIT: Removed list of JAR files...
        Last edited by schu777; Mar 16th, 2010, 11:55 AM.


        • #5
          I put in the commons-lang-2.5 version and it still errored out. After that, I deleted my Build directory AND the deployment directory and that solved it - now I don't know if the 2.5 also helped at this point, but it's working now.