Announcement Announcement Module
Collapse

Spring Modules forum decommissioned in favor of Spring Extensions

As the Spring Modules project has been replaced by the Spring Extensions (http://www.springsource.org/extensions) project, this forum has been decommissioned in favour of Spring Extensions one at:
http://forum.springsource.org/forumdisplay.php?f=44

Please see the Spring Extensions home page for a complete list of current projects in Java, .NET and ActionScript. You can also propose one if you want.

Cheers,
Costin Leau
SpringSource - http://www.SpringSource.com- Spring Training, Consulting, and Support - "From the Source"
http://twitter.com/costinl
See more
See less
Spring Modules 0.9 Release Plan Page Title Module
Move Remove Collapse
This is a sticky topic.
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Modules 0.9 Release Plan

    All,

    Good news! We are currently planning for a 0.9 release at the end of February!

    We are taking this opportunity to review the status of each of the modules, and also as an opportunity to gather some user feedback *1.

    To aid this planning, could you all please view the JIRAs (http://jira.springframework.org/browse/MOD) and comment, or vote on those that you would like included in the 0.9 release *2.

    This is also an opportunity to find out which modules are used, which aren't, which new modules you would like to see and any outstanding feature requests (which should be added as a JIRA as well ).

    As well as reviewing the JIRAs, could you also please respond either to me personally, or to this message with the following information:

    - which modules do you personally use or know of in use
    - which Spring platform you use (2.0, 2.5 etc.)
    - which JDK you are running on

    and any other information you think might be relevant. Please do not post bugs, or usage questions on this thread; please use this forum, or JIRA for those questions.

    Many thanks,

    Colin Yates

    *1 Please consider filling in the survey here http://forum.springframework.org/showthread.php?t=36635
    *2 Due to the nature of Spring Modules, and the fact that it is a community driven project, there is no guarantee that the module owners will be able to implement all requested JIRA issues, however we will do our best!

  • #2
    - which modules do you personally use or know of in use
    cache (but there are several others, like lucene and commons, that I am keen to implement in some projects)

    - which Spring platform you use (2.0, 2.5 etc.)
    2.5

    - which JDK you are running on
    sun 1.5

    Comment


    • #3
      - Modules used :
      cache, drools, apache commons, velocity

      - Spring versions :
      both 2.0.x & 2.5.x

      - JDK :
      Java 5.0

      Comment


      • #4
        - Modules used :
        jcr (Jackrabbit)
        jbpm

        - Spring versions :
        2.0.x
        2.5.x

        - JDK :
        Java 5.0

        Comment


        • #5
          - Modules used :
          jcr (in the process of integrating cache and commons)

          - Spring version :
          2.5 (some projects still on 2.0)

          - JDK version .
          5.0 (with some projects still on 1.4.2, but moving up *soon*)
          Last edited by gehel; Feb 5th, 2008, 08:59 AM.

          Comment


          • #6
            - Modules used :
            bean validation

            - Spring version :
            2.0.x
            2.5

            - JDK version :
            java 6.0

            Comment


            • #7
              - Modules used :
              xt framework

              - Spring version :
              2.5.x

              - JDK version :
              java 6.0

              Comment


              • #8
                Modules used :
                jbpm
                db4o
                cache

                - Spring version :
                2.0

                - JDK version .
                5.0

                Comment


                • #9
                  Survey response

                  Good to know that 0.9 is in the offing!

                  - which modules do you personally use or know of in use

                  valang, XT, declarative cache

                  - which Spring platform you use (2.0, 2.5 etc.)

                  latest 2.5, some 2.0

                  - which JDK you are running on

                  latst Sun 1.5, latest jrockit 1.5

                  Cheers,
                  Alph
                  Last edited by alpheratz; Feb 11th, 2008, 04:34 AM. Reason: forgot cacheing

                  Comment


                  • #10
                    Hello everyone!

                    Good to know that soon will be release a new version of spring module.

                    - Modules used :
                    1) commons validator (alot! please continue to refine this integration)
                    2) velocity
                    3) cache


                    - Spring versions :
                    2.0.x (in production)
                    2.5.x (upgrating..)

                    - JDK :
                    Java 1.4 (yes, i use IBM, please don't forget us! we are the legacy guys)

                    Thanks.
                    Last edited by fpereira; Feb 11th, 2008, 04:17 AM.

                    Comment


                    • #11
                      - Modules used :
                      jcr
                      cache

                      - Spring version :
                      2.0 + 2.5

                      - JDK version .
                      5.0

                      Comment


                      • #12
                        - Modules used :
                        XT framework

                        - Spring version :
                        2.5

                        - JDK version :
                        java 5.0

                        Comment


                        • #13
                          In regards to SpringModules 0.9

                          What are the plans for SpringModules? I know things are starting to get back in motion again and I was just wondering what plans are in store for the project.

                          Some of my questions are as follows:

                          1. What's going to be the base line JDK version supported?

                          Looking at the initial posting of this thread from over a year ago, it seems like there was thought for making it JDK 1.5. I know there’s a lot of legacy applications out there that are using JDK 1.4 and lower, but is this the version that SpringModules is looking to support moving forward? I believe that the project could benefit greatly from upgrading to JDK 1.5 and it’s proven itself stable.

                          2. When will SpringModules support Maven 100%?
                          Looking at the current project, I see it’s built using Ant. Locally, I migrated the Cache project to Maven 2. In this process I also split up the project in the following manner.

                          springmodules-cache-core – The core of SpringModules cache project with the exclusion of the various providers.
                          springmodules-cache-tiger – This portion of the project is for JDK 1.5 support. Depending on the base line support of the JDK, this could be integrated into the core project.
                          springmodules-cache-${provider} – The ${provider} is a place holder for the various vendors supported. E.g., ehcache, jcs, jboss, websphere, etc. Instead of having all of the providers placed under the core project and making the dependency list bloated, I isolated each of the providers into its own project. This is beneficial since users of the project would then select only the provider they intend to use without having to worry about placing a bunch of exclusions in their poms.

                          3. What version of Spring will be supported for the various projects?

                          I know there have been great strides in performance with Spring 2.5.x and I also acknowledge that not everyone has the ability to update their projects because of testing, but there has been patches done to the Spring framework since SpringModules has started.

                          4. What’s the ETA on SpringModules 0.9 release?

                          Best Regards,
                          Richard L. Burton III

                          Comment


                          • #14
                            Any feedback about richard question? release dates?

                            Thanks,
                            Fernando

                            Comment


                            • #15
                              - Modules used :
                              JSR-94
                              jBPM

                              - Spring version :
                              2.0 + 2.5

                              - JDK version :
                              java 5.0

                              Comment

                              Working...
                              X