Announcement Announcement Module

Spring Modules forum decommissioned in favor of Spring Extensions

As the Spring Modules project has been replaced by the Spring Extensions ( project, this forum has been decommissioned in favour of Spring Extensions one at:

Please see the Spring Extensions home page for a complete list of current projects in Java, .NET and ActionScript. You can also propose one if you want.

Costin Leau
SpringSource - Spring Training, Consulting, and Support - "From the Source"
See more
See less
"error message with arguments" in ValangValidator + ValangJavaScriptTranslator .. Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • "error message with arguments" in ValangValidator + ValangJavaScriptTranslator ..


    did anybody had success with configuring "error message with arguments" in ValangValidator

    My Validator is like this

    <bean id="domainObjectValangValidator" class="org.springmodules.validation.valang.ValangValidator">
          <property name="valang">
    	    	{ name : ? IS NOT BLANK : 'Please select Name' : 'errors.required' : 'Name'}
    The Problem is that I get the default message not the one whose key is 'errors.required'. This message has a argument as you can see ..
    errors.required={0} is a required field.
    I get the following message in my log. This obviously states the reason but what I'm looking for is how to make this work. Can anybody shed some light?

    Mar 29, 2007 12:12:46 PM org.springmodules.validation.valang.javascript.ValangJavaScriptTranslator getErrorMessage
    WARNING: Translating error message with arguments is not implemented; using default message

  • #2
    Please Help I also havinf same trouble