Announcement Announcement Module

Spring Modules forum decommissioned in favor of Spring Extensions

As the Spring Modules project has been replaced by the Spring Extensions ( project, this forum has been decommissioned in favour of Spring Extensions one at:

Please see the Spring Extensions home page for a complete list of current projects in Java, .NET and ActionScript. You can also propose one if you want.

Costin Leau
SpringSource - Spring Training, Consulting, and Support - "From the Source"
See more
See less
Spring-modules cache compatible with Spring 1.2.8? Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring-modules cache compatible with Spring 1.2.8?

    Hello all...

    Is the caching module (v0.7) compatible with Spring 1.2.8?
    I have some issues in my app which are leading me to think that it is not.
    Anybody knows for sure?

    Thanks in advance!

  • #2
    Can you please post your issues? In the last 2 releases I think we have used Spring 2.0-m4 and in 0.7 we moved to 2.0.1. Caching module has some namespace handling schemas so it does depend on Spring 2 - however, the code is lazy so when using Spring 1.2, the handler classes are not used.


    • #3
      When trying to perform caching with EhCache, i get: ndMethod()

      And when i look at the Spring javadoc for org.springframework.util.ReflectionUtils in Spring 1.2, there is no "findMethod()" method, while in 2.0.1, such a method indeed exists.


      • #4
        Seems indeed that the caching module relies on some Spring 2.0 functionality. Please raise an issue on JIRA - I'm not sure if ReflectionUtils will make it into 1.2.9 but it's functionality can be externalized to allow usage of caching module of Spring 1.2.x branch.


        • #5
          I've taken the ReflectionUtils from Spring 2.0.1, put it in my classpath, and now caching works just fine

          I will rise an issue on the JIRA today..

          Thank you for your time