Announcement Announcement Module
Collapse

JavaConfig forum decommissioned in favor of Core Container

As described at

http://static.springsource.org/sprin...fig/README.TXT

key features of the Spring JavaConfig project have been migrated into the core Spring Framework as of version 3.0.

Please see the Spring 3.0 documentation on @Configuration and @Bean support:

http://static.springsource.org/sprin...tml#beans-java

For any questions related to @Configuration classes and @Bean methods in Spring 3.0, please post in the dedicated 'Core Container' forum at

http://forum.springsource.org/forumdisplay.php?f=26
See more
See less
spring-javaconfig not compatible with spring-beans 3.0.0.RC1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • spring-javaconfig not compatible with spring-beans 3.0.0.RC1

    Hi,

    spring-javaconfig is not compatible with spring 3.0.0.RC1. The interfaces org.springframework.config.java.annotation.Configu ration uses the enumeration value org.springframework.beans.factory.annotation.Autow ire.INHERITED which is not part of 3.0.0.RC1.

    Does anybody know why Autowire.INHERITED has been removed? What can I do to circumvent this issue. Currently I get compile errors like this:

    Code:
    error: in class file org\springframework\config\java\annotation\Bean.class(org\springframework\config\java\annotation:Bean.class): unknown enum constant org.springframework.beans.factory.annotation.Autowire.INHERITED
    error: in class file org\springframework\config\java\annotation\Configuration.class(org\springframework\config\java\annotation:Configuration.class): unknown enum constant org.springframework.beans.factory.annotation.Autowire.INHERITED
    Thanks,
    Klaus

  • #2
    Javaconfig is part of spring 3. So you wouldn't need to mix both...

    Comment

    Working...
    X