Announcement Announcement Module
Collapse

Spring Dynamic Modules forum decommissioned in favor of Eclipse Gemini Blueprint

With the official first release of Eclipse Gemini Blueprint shipped, the migration of the Spring Dynamic Modules code base to the Eclipse Foundation, as part of the Gemini project, has been completed.

As such, this forum has been decommissioned in favour of the Eclipse Gemini forums.
See more
See less
Strange configuration behaviour around <osgi:list> Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange configuration behaviour around <osgi:list>

    Hi all,

    when entering the following bean configuration

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <beans:beans xmlns:osgi="http://www.springframework.org/schema/osgi"
                 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                 xmlns:beans="http://www.springframework.org/schema/beans"
                 xsi:schemaLocation="http://www.springframework.org/schema/osgi  
                                     http://www.springframework.org/schema/osgi/spring-osgi-1.0.xsd
                                     http://www.springframework.org/schema/beans   
                                     http://www.springframework.org/schema/beans/spring-beans-2.5.xsd">
    	
    	<osgi:service ref="personManager" interface="be.nnuytten.pm.model.IPersonManager" />
    	
    	<osgi:list id="personListeners" interface="be.nnuytten.pm.model.IPersonListener" cardinality="0..N">
    		<osgi:listener ref="personManager" bind-method="addPersonListener" unbind-method="removePersonListener" />
    	</osgi:list>
    </beans:beans>
    the following error pops up at the
    Code:
    <osgi:service>
    line:

    Code:
    Error occured processing XML 'Could not initialize class org.springframework.osgi.service.exporter.support.OsgiServiceFactoryBean'. See Error Log for more details
    Does this perhaps have anything to do with the use of the
    Code:
    <osgi:list>
    a bit further?
    The error pops up even before running anything, so the error log wouldn't show much. Unless there's another one I don't know about?

    Help is kindly appreciated!
Working...
X