Announcement Announcement Module
Collapse

Spring Dynamic Modules forum decommissioned in favor of Eclipse Gemini Blueprint

With the official first release of Eclipse Gemini Blueprint shipped, the migration of the Spring Dynamic Modules code base to the Eclipse Foundation, as part of the Gemini project, has been completed.

As such, this forum has been decommissioned in favour of the Eclipse Gemini forums.
See more
See less
Spring context fails without network connection Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring context fails without network connection

    Just discovered that I'm unable to start an RCP app when no network connection is present:

    Code:
    !ENTRY org.springframework.beans.factory.xml.XmlBeanDefinitionReader 2 30000 2011-01-18 20:12:14.316
    !MESSAGE Ignored XML validation warning
    !STACK 0
    org.xml.sax.SAXParseException: schema_reference.4: Failed to read schema document 'http://www.springframework.org/schema/beans/spring-beans-3.0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
    	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
    	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.warning(ErrorHandlerWrapper.java:96)
    	...
    When a network connection is present, the application works fine, but Spring fetches the following two schemas repeatedly (once for each Spring-enabled bundle) on startup:

    Here's how all spring-context.xml files start:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <beans 
        xmlns="http://www.springframework.org/schema/beans" 
        xmlns:context="http://www.springframework.org/schema/context" 
        xmlns:osgi="http://www.springframework.org/schema/osgi"
        xmlns:tx="http://www.springframework.org/schema/tx"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="
            http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-3.0.xsd
            http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-3.0.xsd
            http://www.springframework.org/schema/osgi http://www.springframework.org/schema/osgi/spring-osgi-2.0-m1.xsd
            http://www.springframework.org/schema/tx http://www.springframework.org/schema/tx/spring-tx-3.0.xsd"
        osgi:default-timeout="10000"
    >
    I'm using the org.springframework.beans-3.0.5.RELEASE.jar bundle.

    Anyone else encountered this issue?

  • #2
    For the record: The spring-beans bundle (which contains the two schemas) needs to be started (before the spring extender bundle is started). See https://jira.springsource.org/browse/OSGI-810.

    Comment

    Working...
    X