Announcement Announcement Module
Collapse

Spring Dynamic Modules forum decommissioned in favor of Eclipse Gemini Blueprint

With the official first release of Eclipse Gemini Blueprint shipped, the migration of the Spring Dynamic Modules code base to the Eclipse Foundation, as part of the Gemini project, has been completed.

As such, this forum has been decommissioned in favour of the Eclipse Gemini forums.
See more
See less
Proper bundle start order for using Tomcat with Spring DM? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Proper bundle start order for using Tomcat with Spring DM?

    Dear All:

    I am trying to use Spring DM with Tomcat (or Jetty as you noticed in my other post). I am having luck with neither.

    I seem to have all the modules running, except com.springsource.org.apache.jasper.springsource_6. 0.29.S2-r1559
    which is a fragment bundle (and creates a nice circular dependency on the SpringSource Enterprise Bundle Repository Website):
    http://www.springsource.com/reposito...chQuery=tomcat
    (in fact catalina depends on itself!)

    In any case, here is the error I get:
    Code:
    osgi> Persistence bundle starting...
    Persistence bundle started.
    Oct 15, 2010 5:57:43 PM org.springframework.scheduling.timer.TimerTaskExecutor afterPropertiesSet
    INFO: Initializing Timer
    Oct 15, 2010 5:57:43 PM org.springframework.osgi.web.extender.internal.activator.WarLoaderListener start
    INFO: Starting [org.springframework.osgi.web.extender] bundle v.[1.2.1]
    Oct 15, 2010 5:57:43 PM org.springframework.osgi.web.extender.internal.activator.WarListenerConfiguration <init>
    INFO: No custom extender configuration detected; using defaults...
    Oct 15, 2010 5:57:43 PM org.springframework.osgi.web.deployer.tomcat.TomcatWarDeployer afterPropertiesSet
    INFO: No Catalina Service set; looking for one in the OSGi service registry...
    Oct 15, 2010 5:57:43 PM org.springframework.osgi.service.importer.support.internal.aop.ServiceDynamicInterceptor afterPropertiesSet
    INFO: Looking for mandatory OSGi service dependency for bean [] matching filter (objectClass=org.apache.catalina.Service)
    Oct 15, 2010 5:57:48 PM org.springframework.osgi.web.deployer.tomcat.TomcatWarDeployer afterPropertiesSet
    SEVERE: No Catalina Service found, bailing out
    org.springframework.osgi.service.ServiceUnavailableException: service matching filter=[(objectClass=org.apache.catalina.Service)] unavailable
    	at org.springframework.osgi.service.importer.support.internal.aop.ServiceDynamicInterceptor.getTarget(ServiceDynamicInterceptor.java:419)
    	at org.springframework.osgi.service.importer.support.internal.aop.ServiceDynamicInterceptor.afterPropertiesSet(ServiceDynamicInterceptor.java:472)
    	at org.springframework.osgi.service.importer.support.OsgiServiceProxyFactoryBean.createProxy(OsgiServiceProxyFactoryBean.java:215)
    	at org.springframework.osgi.service.importer.support.AbstractServiceImporterProxyFactoryBean.getObject(AbstractServiceImporterProxyFactoryBean.java:86)
    	at org.springframework.osgi.service.importer.support.OsgiServiceProxyFactoryBean.getObject(OsgiServiceProxyFactoryBean.java:161)
    	at org.springframework.osgi.web.deployer.internal.util.Utils.createServerServiceProxy(Utils.java:121)
    	at org.springframework.osgi.web.deployer.tomcat.TomcatWarDeployer.afterPropertiesSet(TomcatWarDeployer.java:90)
    	at org.springframework.osgi.web.extender.internal.activator.WarListenerConfiguration.createDefaultWarDeployer(WarListenerConfiguration.java:197)
    	at org.springframework.osgi.web.extender.internal.activator.WarListenerConfiguration.<init>(WarListenerConfiguration.java:105)
    	at org.springframework.osgi.web.extender.internal.activator.WarLoaderListener$1.run(WarLoaderListener.java:361)
    	at java.lang.Thread.run(Thread.java:619)
    Oct 15, 2010 5:57:48 PM org.springframework.osgi.web.extender.internal.activator.WarLoaderListener$1 run
    SEVERE: Cannot property start Spring DM WebExtender; stopping bundle...
    org.springframework.osgi.OsgiException: Cannot create Tomcat deployer
    	at org.springframework.osgi.web.extender.internal.activator.WarListenerConfiguration.createDefaultWarDeployer(WarListenerConfiguration.java:201)
    	at org.springframework.osgi.web.extender.internal.activator.WarListenerConfiguration.<init>(WarListenerConfiguration.java:105)
    	at org.springframework.osgi.web.extender.internal.activator.WarLoaderListener$1.run(WarLoaderListener.java:361)
    	at java.lang.Thread.run(Thread.java:619)
    Caused by: org.springframework.osgi.service.ServiceUnavailableException: service matching filter=[(objectClass=org.apache.catalina.Service)] unavailable
    	at org.springframework.osgi.service.importer.support.internal.aop.ServiceDynamicInterceptor.getTarget(ServiceDynamicInterceptor.java:419)
    	at org.springframework.osgi.service.importer.support.internal.aop.ServiceDynamicInterceptor.afterPropertiesSet(ServiceDynamicInterceptor.java:472)
    	at org.springframework.osgi.service.importer.support.OsgiServiceProxyFactoryBean.createProxy(OsgiServiceProxyFactoryBean.java:215)
    	at org.springframework.osgi.service.importer.support.AbstractServiceImporterProxyFactoryBean.getObject(AbstractServiceImporterProxyFactoryBean.java:86)
    	at org.springframework.osgi.service.importer.support.OsgiServiceProxyFactoryBean.getObject(OsgiServiceProxyFactoryBean.java:161)
    	at org.springframework.osgi.web.deployer.internal.util.Utils.createServerServiceProxy(Utils.java:121)
    	at org.springframework.osgi.web.deployer.tomcat.TomcatWarDeployer.afterPropertiesSet(TomcatWarDeployer.java:90)
    	at org.springframework.osgi.web.extender.internal.activator.WarListenerConfiguration.createDefaultWarDeployer(WarListenerConfiguration.java:197)
    	... 3 more
    Oct 15, 2010 5:57:48 PM org.springframework.scheduling.timer.TimerTaskExecutor destroy
    INFO: Cancelling Timer
    and the equinox start order (I am using Pax Provision):
    Code:
    osgi>  ss
    
    Framework is launched.
    
    id	State       Bundle
    0	ACTIVE      org.eclipse.osgi_3.6.0.v20100517
    1	ACTIVE      com.springsource.javax.servlet_2.5.0
    2	ACTIVE      com.springsource.org.aopalliance_1.0.0
    3	ACTIVE      com.springsource.org.apache.commons.logging_1.1.1
    4	ACTIVE      org.springframework.aop_3.0.4.RELEASE
    5	ACTIVE      org.springframework.beans_3.0.4.RELEASE
    6	ACTIVE      org.springframework.context_3.0.4.RELEASE
    7	ACTIVE      org.springframework.core_3.0.4.RELEASE
    8	ACTIVE      org.springframework.web_3.0.4.RELEASE
    9	ACTIVE      org.springframework.expression_3.0.4.RELEASE
    10	ACTIVE      org.springframework.context.support_3.0.4.RELEASE
    11	ACTIVE      com.springsource.javax.annotation_1.0.0
    12	ACTIVE      com.springsource.javax.ejb_3.0.0
    13	ACTIVE      com.springsource.javax.xml.rpc_1.1.0
    14	ACTIVE      com.springsource.javax.xml.soap_1.3.0
    15	ACTIVE      com.springsource.javax.activation_1.1.1
    16	ACTIVE      com.springsource.javax.mail_1.4.1
    17	ACTIVE      com.springsource.javax.persistence_1.99.0
    18	ACTIVE      com.springsource.javax.xml.ws_2.1.1
    19	ACTIVE      com.springsource.javax.xml.bind_2.2.0
    20	ACTIVE      com.springsource.javax.xml.stream_1.0.1
    21	RESOLVED    com.springsource.org.apache.coyote.springsource_6.0.29.S2-r1559
    	            Master=28
    22	ACTIVE      com.springsource.org.apache.juli.extras.springsource_6.0.29.S2-r1559
    23	INSTALLED   com.springsource.org.apache.jasper.springsource_6.0.29.S2-r1559
    24	ACTIVE      com.springsource.javax.el_1.0.0
    25	ACTIVE      com.springsource.javax.servlet.jsp_2.1.0
    26	ACTIVE      com.springsource.org.apache.el.springsource_6.0.29.S2-r1559
    27	ACTIVE      com.springsource.org.apache.jasper.org.eclipse.jdt_6.0.16
    28	ACTIVE      com.springsource.org.apache.catalina.springsource_6.0.29.S2-r1559
    	            Fragments=21
    29	ACTIVE      com.springsource.org.aspectj.tools_1.6.8.RELEASE
    30	ACTIVE      org.springframework.osgi.core_1.2.1
    31	ACTIVE      org.springframework.osgi.io_1.2.1
    32	ACTIVE      org.springframework.osgi.web_1.2.1
    33	RESOLVED    org.springframework.osgi.web.extender_1.2.1
    34	ACTIVE      wrap_mvn_javax.validation_validation-api_1.0.0.GA_0.0.0
    35	ACTIVE      mvc-basic_1.0.0.SNAPSHOT
    36	ACTIVE      org.springframework.web.servlet_3.0.4.RELEASE
    37	ACTIVE      slf4j.api_1.5.10
    38	ACTIVE      jcl.over.slf4j_1.5.10
    39	INSTALLED   slf4j.log4j12_1.5.10
    41	ACTIVE      joda-time_1.6.0
    
    osgi> start 23
    org.osgi.framework.BundleException: A fragment bundle cannot be started: com.springsource.org.apache.jasper.springsource_6.0.29.S2-r1559 [23]
    Thank you _very much_ for any hints!

    Misha

  • #2
    Have you had any luck and solved this problem? I am currently stuck at the exact same step. Any suggestions on solving this error??
    What am I missing?

    Comment

    Working...
    X