Announcement Announcement Module
Collapse

Spring Dynamic Modules forum decommissioned in favor of Eclipse Gemini Blueprint

With the official first release of Eclipse Gemini Blueprint shipped, the migration of the Spring Dynamic Modules code base to the Eclipse Foundation, as part of the Gemini project, has been completed.

As such, this forum has been decommissioned in favour of the Eclipse Gemini forums.
See more
See less
Uses exception Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Uses exception

    Hi

    I'm trying to deploy a bundle that makes use of RESTful web services using CXF within DMSERVER 2.0.2. I am getting the following error when I try to deploy it

    Caused by: com.springsource.kernel.osgi.framework.UnableToSat isfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'testDistribService' at version '0.1.0': Cannot resolve: testDistribService
    Resolver report:
    A Require-Bundle could not be resolved. Caused by missing constraint in bundle <testDistribService_0.1.0>
    constraint: <Require-Bundle: javax.ws.rs; bundle-version="0.0.0">
    Uses violation: <Import-Package: javax.xml.ws.wsaddressing; version="[0.0.0,3.0.0)"> in bundle <org.apache.cxf.cxf-bundle_2.1.10>
    Resolver reported uses conflict for import


    I'm not sure what's wrong here, as my manifest states explicitly the version of Jax-rs to use.

    Manifest-Version: 1.0

    Export-Package: distributed.service

    Built-By: kiren

    Tool: Bnd-0.0.357

    Bundle-Name: Test Distributed OSGI service

    Created-By: Apache Maven Bundle Plugin

    Require-Bundle: org.apache.cxf.cxf-bundle,javax.ws.rs

    Build-Jdk: 1.6.0_20

    Bundle-Version: 0.1.0

    Bnd-LastModified: 1283352494551

    Bundle-ManifestVersion: 2

    Bundle-Activator: mydistributedservice.Activator

    Bundle-SymbolicName: testDistribService

    Import-Package: META-INF.cxf,META-INF.cxf.osgi,javax.ws.rs;version="1.

    0",javax.wsdl,org.apache.cxf.binding;version="2.2" ,org.apache.cxf.bus

    ;version="2.2",org.apache.cxf.bus.resource;version ="2.2",org.apache.c

    xf.bus.spring;version="2.2",org.apache.cxf.configu ration.spring;versi

    on="2.2",org.apache.cxf.jaxrs.utils;version="2.2", org.apache.cxf.reso

    urce;version="2.2",org.apache.servicemix.cxf.trans port.http_osgi,org.

    osgi.framework;version="1.2",org.springframework.b eans.factory.config

    ;version="2.5"

    I've installed the com.springsource.javax.ws.rs-1.0.0 bundle on the server as well, but it does not seem to resolve it.
Working...
X