Announcement Announcement Module

Spring Dynamic Modules forum decommissioned in favor of Eclipse Gemini Blueprint

With the official first release of Eclipse Gemini Blueprint shipped, the migration of the Spring Dynamic Modules code base to the Eclipse Foundation, as part of the Gemini project, has been completed.

As such, this forum has been decommissioned in favour of the Eclipse Gemini forums.
See more
See less
Configuring extender timeout via fragment Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Configuring extender timeout via fragment


    I have some problems configuring dependencies.wait.time by adding a fragment to the spring osgi extender as described in chapter 6.2 of the the reference documentation. I am using version 1.2.0 of spring DM.

    The fragment contains the following bean definition:

    <util:properties id="extenderProperties">
      <prop key="dependencies.wait.time">44</prop>
    In ContextLoaderListener.maybeCreateApplicationContex tFor(Bundle) in line 763 I can see that this value 44 is read correctly. So I can be sure that the dependency to the host bundle is resolved. But the long variable timeout that the value is assigned to is never read from.

    Is this a known behaviour/bug? Or am I missing something?

    I checked the according source code passage in version 1.2.1. It does not seem to have changed since 1.2.0.

    Regards, Jens

  • #2
    Not that I know of - can you enable debugging?
    The setting should kick in (and be applied) for bundles that do not declare a custom grace period/wait-for-dependencies setting.


    • #3
      Hi Costin,

      what debugging facilities are available?

      Did you have a quick look at the source code location I mentioned? IMHO the timeout is never correctly (though read correctly). But maybe I miss something.

      -- Jens


      • #4
        I did and you're right - it's a bug. The timeout variable is computed but not assigned internally. Could you please raise an issue?
        Thank you,


        • #5
          I did: