Announcement Announcement Module
Collapse

Spring Dynamic Modules forum decommissioned in favor of Eclipse Gemini Blueprint

With the official first release of Eclipse Gemini Blueprint shipped, the migration of the Spring Dynamic Modules code base to the Eclipse Foundation, as part of the Gemini project, has been completed.

As such, this forum has been decommissioned in favour of the Eclipse Gemini forums.
See more
See less
org.springframework.osgi.extender not active Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • org.springframework.osgi.extender not active

    Hi All,

    I ran into this problem yesterday, I am relatively new to Spring DM and OSGi, but trying to build solid background through reading books, docs and tutorials.

    The scenario trying to implement from scratch is pretty simple, and actually with older versions I have,ugly constructed, but working samples...

    So I start to build maven-eclipse-spring simple project following a tutorial, in brief - Eclipse project, build with maven plug-in and follwing dependencies:

    spring-test-2.5.6.jar
    commons-logging-1.1.1.jar
    junit-3.8.1.jar
    spring-core-2.5.6.jar
    spring-context-2.5.6.jar
    aopalliance-1.0.jar
    spring-beans-2.5.6.jar

    I have built some foo-service, which to register during the extender.
    Also using SpringIDE to create a Target platform in eclipse.
    Everithyng builds, compiles just fine.
    When I start the project I have the following bundles:

    Code:
    id	State       Bundle
    0	ACTIVE      org.eclipse.osgi_3.4.0.v20080605-1900
    837	ACTIVE      org.springframework.osgi.io_1.1.2.B
    838	ACTIVE      org.springframework.test_2.5.6
    839	ACTIVE      spring.source_2.5.6
    840	ACTIVE      org.springframework.osgi.extensions.annotation_1.1.2.B
    841	ACTIVE      org.springframework.osgi.core_1.1.2.B
    842	ACTIVE      org.springframework.context.support_2.5.6
    843	ACTIVE      org.springframework.osgi.cglib-nodep.osgi_2.1.3.SNAPSHOT
    844	ACTIVE      com.springsource.slf4j.api_1.5.6
    	            Fragments=855
    845	ACTIVE      org.springframework.osgi.backport-util-concurrent.osgi_3.1.0.SNAPSHOT
    846	RESOLVED    org.springframework.osgi.extender_1.1.2.B
    847	ACTIVE      springdm.source_1.1.2.B
    848	ACTIVE      org.springframework.aop_2.5.6
    849	ACTIVE      org.springframework.osgi.asm.osgi_2.2.3.SNAPSHOT
    850	ACTIVE      org.springframework.core_2.5.6
    851	ACTIVE      org.springframework.context_2.5.6
    852	RESOLVED    org.springframework.osgi.test_1.1.2.B
    853	ACTIVE      org.springframework.beans_2.5.6
    854	ACTIVE      org.springframework.osgi.junit.osgi_3.8.2.SNAPSHOT
    855	RESOLVED    com.springsource.slf4j.jcl_1.5.6
    	            Master=844
    856	ACTIVE      com.springsource.slf4j.org.apache.commons.logging_1.5.6
    857	ACTIVE      org.springframework.osgi.aopalliance.osgi_1.0.0.SNAPSHOT
    873	ACTIVE      abacus.services_1.0.0.qualifier
    874	ACTIVE      com.springsource.org.apache.commons.logging_1.1.1
    as you can see the extender is only RESOLVED

    The error trying to start it:

    Code:
    osgi> start 846
    getService[System Bundle [0]]({org.eclipse.osgi.framework.console.CommandProvider}={service.ranking=2147483647, service.pid=0.org.eclipse.core.runtime.internal.adaptor.EclipseCommandProvider, service.vendor=Eclipse.org, service.id=19})
    getService[System Bundle [0]]({org.eclipse.osgi.framework.console.CommandProvider}={service.ranking=2147483647, service.id=2})
    Bundle: Active sl = 6; Bundle 846 sl = 4
    dispatchBundleEvent[System Bundle [0]](org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider@4a5ab2)
    Starting org.springframework.osgi.extender
    java.lang.NullPointerException ......................
    .........................................
    org.osgi.framework.BundleException: The activator org.springframework.osgi.extender.internal.activator.ContextLoaderListener for bundle org.springframework.osgi.extender is invalid
    	at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:146)
    	...............................
    For the following error I have only discover some posts blaming the log libraries. I try to use slf4j-simple and log4j with switching off the commons-logging from run configuration, but with no luck.

    So any opinions, what I have done wrong or missing here is welcome.

    Best regards,
    Ivan B.

  • #2
    I know it seems pretty lame, but everything seems to be just fine and the error didn't give me enough information what went wrong... so instead of reverting to older versions i prefer to understand what is really going on even if it will bring shame on me and my experience as developer ...

    Comment


    • #3
      org.springframework.osgi.extender not active

      Hi Ivan,
      this is a thing i run into some times. The thing which helps me usually is copying and editing the file config.ini as described here: http://swissdev.blogspot.com/2008/06...spring-dm.html.
      The funny thing with my eclipse installation is that after copying and editing the ini and once trying to start the app with the local ini I have to manually switch back to the generated ini and then it works. Reproducable...
      Regards,
      dagmar

      Comment


      • #4
        Portal, I've seen this problems as well but usually only when using equinox from the command line. I've never encountered them during the integration tests when the OSGi platform is used directly, w/o any 'management' tool on top.
        The problem usually boils down to the way the bundles are installed and the cache used by the OSGi platform.
        My recommendation is to start with a clean plate, with osgi.clean option (i.e. erase the case every time) and with the latest build of equinox. 3.4.2 or 3.5.0 should be good enough.
        Also, upgrading Spring DM would be a good idea.

        Comment

        Working...
        X