Announcement Announcement Module
Collapse

Spring Dynamic Modules forum decommissioned in favor of Eclipse Gemini Blueprint

With the official first release of Eclipse Gemini Blueprint shipped, the migration of the Spring Dynamic Modules code base to the Eclipse Foundation, as part of the Gemini project, has been completed.

As such, this forum has been decommissioned in favour of the Eclipse Gemini forums.
See more
See less
Exception loading jetty extender Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exception loading jetty extender

    I got an exception when trying to launch an application that uses Spring DM1.1/equinox3.3/jdk6 that is related to loading XML Schema files. The exception is included as an attachment.

    I have tried to change the URL in the namespace to spring-beans-2.5.xsd in the jetty extender bundle as suggested in the JIRA-OSGI-514 issue but to no avail.

    In the same runtime I have other bundles exporting Spring beans as OSGi services without any problem, but for some reason the jetty bundle is not able to load the XML schema.

  • #2
    Make sure the spring-extender bundle is installed and started. I recommend using the samples provided out of the box (see the 1.2.x distribution as well) as a starting point.

    Comment


    • #3
      Not related to extender bundles

      Other Spring beans are correctly instantiated in the same launch configuration, the exception appears only with the jetty-extender bundle.

      I have tried the same launch configuration with a clean Eclipse installation and the exception dissapears. However, once I edit a spring-context.xml file it happens again.

      I suspect that it might be related to some caching of the XSD files that Eclipse is doing, beacuse schemas are being searched in different locations instead of inside spring JARs (following the information in META-INF/spring.schemas). Somehow the packaged schemas are ignored...

      Might this be possible?

      Comment


      • #4
        I haven't used PDE too much - consider running the test from the command line and see whether you encounter any issues. Additionally, turn on logging to TRACE level and see whether you can spot any problems.

        Comment

        Working...
        X